Lineage OS 14.1 for Redmi 3/Prime [download and guide]

Lineage OS 14.1

Android Nougat 7.1.1 base Lineage OS 14.1 is available for Xiaomi Redmi 3/Prime.

There is no word from Xiaomi to release Nougat update for Redmi 3/Prime. Try Lineage OS 14.1 until official ROM is not available.

Pre-requisite:

  • TWRP installed Xiaomi Redmi 3/Prime.
  • Do not try this on another device.
  • Bootloader unlocked device.
  • Enabled USB debugging. To do this Go to Settings->Developer options
  • At least 70% charged phone.

Note: Take full back-up before you proceed. Flashing custom ROM may void your warranty. Xiaomi Ninja is not responsible for any kind of damage.

Here is the step by step guideline to install Lineage OS 14.1 for Redmi 3/Prime:

Step 1: Firstly, you need to download the ROM. Click here to download the ROM.

Step 2: Download suitable GAPPS for your device. Click here to download GAPPS.

Step 3: Put the downloaded file into device Internal storage [Not inside any folder].

Step 4: Now boot the device into TWRP recovery mode. To do this press volume down and power button at the same time.

Step 5: Perform a factory reset. To do this go to Wipe and swipe the blue button to perform a factory reset.

Step 6: Return to recovery main menu window and click on “Install”. Now navigate to the downloaded ROM file and choose it. Then press “Add more Zip” and choose the GAPPS package. Then swipe the blue button to start flashing. Be careful that, first you have to choose ROM Zip then GAPPS package.

The whole process can take 5-10 minutes. Wait for the completion and Reboot the device when flashing is finished.

Now you have successfully installed Android Nougat 7.1.1 base Lineage OS 14.1 on Xiaomi Redmi 3/Prime. Enjoy!

  • Pascoal Soares

    Hi for Redmi 3s Prime , can i know what Gapps package shall i download is it ARM or ARM64 ?

    • Dawid Szemborowski

      ARM64 if you shill want to know

  • MK Tuhin

    This ROM I can use Redmi 3 pro…?

  • Faris Najib

    Hi. I am using Redmi 3 Pro. I am rooting my phone for the first time tbh. How to know what Gapps package to be downloaded for my phone?